Issue: Getting error message when trying to connect to the Listener service.

Cause: Changed IP address on Server
(Was working fine. It happened after we changed IPs on the RDS service the listener was installed on.)

Resolution: 

Check the listener.config file which is placed in ./sage client/manage application subfolder. There are can be linking to specific up address. If the up address tag is not equal to 0.0.0.0 specify the new up address there and save the file. (Please note that you need to edit the file by using text editor opened "as administrator", otherwise you can't write to program files (86) directly.

 

<?xml version="1.0"?>

<configuration>

  <configSections>

    <sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">

      <section name="Scanco.WarehouseAutomation.My.MySettings" type="System.Configuration.ClientSettingsSection, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />

    </sectionGroup>

  </configSections>

  <runtime>

    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">

      <probing privatePath="Framework;Warehouse Automation;Interop Assemblies;Primary Interop Assemblies" />

    </assemblyBinding>

  </runtime>

  <system.diagnostics>

    <trace autoflush="true" useGlobalLock="true">

      <listeners>

        <add name="FileLog" />

        <add name="EventLog" />

        <remove name="Default" />

      </listeners>

    </trace>

    <sources>

      <source name="DefaultSource">

        <listeners>

          <remove name="Default" />

        </listeners>

      </source>

    </sources>

    <sharedListeners>

      <add name="FileLog" type="Microsoft.VisualBasic.Logging.FileLogTraceListener, Microsoft.VisualBasic, Version=8.0.0.0,Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" initializeData="FileLogWriter" autoFlush="True" location="ExecutableDirectory" baseFileName="Listener">

        <filter type="System.Diagnostics.EventTypeFilter" initializeData="Information" />

     </add>

      <add name="EventLog" type="System.Diagnostics.EventLogTraceListener" initializeData="ScancoListener">

        <filter type="System.Diagnostics.EventTypeFilter" initializeData="Information" />

      </add>

    </sharedListeners>

  </system.diagnostics>

  <!--<system.serviceModel>

    <client>

      <endpoint name="LocalLicenseServiceEndpoint"

                address="http://localhost:6730/Local/LicenseService/"

                binding="basicHttpBinding"

                contract="Scanco.Workstation.Licensing.Communication.ILocalLicense" />

    </client>

  </system.serviceModel>-->

  <applicationSettings>

    <Scanco.WarehouseAutomation.My.MySettings>

      <setting name="DefaultIPAddress" serializeAs="String">

        <value>0.0.0.0</value>   =  REPLACE with NEW IP ADDRESS

      </setting>

    </Scanco.WarehouseAutomation.My.MySettings>

  </applicationSettings>

</configuration>